Skip to content

MindConnect Library – Dependencies

  • CMake is recommended for cross-platform building of MCL although developers can choose to use other options to build MCL. CMake version 3.10 or later is required.

  • LibCurl is used as the default HTTP client in MCL but developers have the option to easily replace LibCurl with other HTTP client implementations. Make sure LibCurl is installed on your system before building MCL if you are going to use LibCurl as the HTTP client. Steps to build LibCurl for your target system are described in the following sections of this document. Developers are encouraged to use newer versions of LibCurl but note that MCL is tested with LibCurl version 7.65.3.

    Please make sure your HTTP client implementation is configured to use TLS v1.2 implementation.

  • OpenSSL is used as the default TLS and cryptography library but developers have the option to easily replace OpenSSL with other implementations. Make sure OpenSSL is installed on your system before building MCL if you are going to use OpenSSL as TLS and cryptography library. Steps to build OpenSSL are described in the following sections of this document. Developers are encouraged to use newer versions of OpenSSL 1.1.x but note that MCL is tested with OpenSSL version 1.1.1c.

    One of following ciphers must be supported and configured for SSL handshaking:

    1
    2
    3
    4
    5
    6
    7
    8
        AES128-SHA256
        AES256-SHA256
        AES128-GCM-SHA256
        AES256-GCM-SHA384
        ECDHE-RSA-AES128-SHA256
        ECDHE-RSA-AES256-SHA384
        ECDHE-RSA-AES128-GCM-SHA256
        ECDHE-RSA-AES256-GCM-SHA384
    

    In order to verify the correctness of the MindSphere's certificate please enable host and peer verification.

  • If you want to have unit and integration test executables also built with cmake, please ensure that ruby is installed and available on the path. If you do not have ruby on your path no test executables will be generated.

  • Doxygen is used to generate reference documentation. If you want a local copy of the reference documentation, Doxygen has to be installed on your host environment.

Any questions left?

Ask the community


Except where otherwise noted, content on this site is licensed under the MindSphere Development License Agreement.